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About This Manual  v

ABOUT THIS MANUAL

The SCOPIA Connector for IBM Lotus Sametime Installation and 
Administration Guide provides information for administrators and end users 
about SCOPIA Connector deployment, and installation in the IBM Lotus 
Sametime environment. 

Note The SCOPIA Connector plug-in works with the following IBM product 
versions:

� Sametime 7.5
� Sametime 7.5.1
� Sametime 7.5.1 CF1
� Sametime 8.0 and 8.0.1
� Lotus Notes 8.0

This manual refers to options available in Sametime 8.0. 
Configuration options may vary according to the product version you are using. 

FEEDBACK The team at RADVISION constantly endeavors to provide accurate and 
informative documentation. If you have comments or suggestions regarding 
improvements to future publications, we would value your feedback.
Please send your comments to doc_comments@radvision.com.
We thank you for your contribution.

mailto:doc_comments@radvision.com?subject=Query: SCOPIA Connector version 5.7
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1
INSTALLING THE SCOPIA CONNECTOR 
PLUG-IN

This section describes how administrators or end users can automatically deploy 
the SCOPIA Connector plug-in throughout a network, and how end users can 
manually install the plug-in on a Sametime Connect client.
This section describes the following topics:

� Installing the Software from the CD-ROM on page 2
� Update Sites on page 3
� Distribution Methods for the SCOPIA Connector Plug-in on page 3
� How to Automatically Deploy the Plug-in on page 4
� Manually Installing the Plug-in from an Update Site on page 6
� Preventing Manual Downloading on page 7
� Installing the Plug-in without an HTTP Server on page 7
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Installing the Software from the CD-ROM

INSTALLING THE 
SOFTWARE FROM 
THE CD-ROM

Install the SCOPIA Connector plug-in directly from the SCOPIA Desktop 
CD-ROM.

 ) Procedure

1 Insert the CD-ROM.
2 Wait for the autorun menu screen to display.
3 Select SCOPIA Connector for IBM Lotus Sametime.
4 Select Install Update Site.
5 Click the setup.exe file and follow the on-screen instructions.

The Choose Installation Location screen detects if SCOPIA Desktop is 
installed.

6 If SCOPIA Desktop is detected, the installer attempts to create 
an update site at 
<installdir>/Tomcat/webapps/ROOT/sametime

The default update site URL is http://server/sametime.
7 Alternatively, you can instruct the installer to create an update 

site at a different location.
These necessary files must either be placed under a Sametime update site 
or should be distributed manually.

8 If SCOPIA Desktop is not detected, define the location at 
which you want the installer to place the files needed for an 
update site.
By default, the installer places the files at
\Program Files\Radvision\SCOPIA Connector for IBM 
Lotus Sametime

You must either place the files needed for an update site under a 
Sametime update site, or distribute them manually.
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Update Sites

UPDATE SITES An update site is a specific directory layout with an XML file that specifies all 
the available plug-ins. The method of how the update site is presented to the 
client can vary (for example, as a web site or via the local file system).
If SCOPIA Desktop is detected when installing SCOPIA Connector, an Eclipse 
update site is created for you in the SCOPIA Desktop installation directory at   
<installdir>/Tomcat/webapps/ROOT/sametime. You can use the update 
site at this location, or you can copy the files from the update site to a location of 
your choice.
We recommend using the installer to create the update site. This is usually set up 
on the same server as SCOPIA Desktop.
If you already have plug-ins that you automatically push via an update site, you 
need to merge the SCOPIA Connector site.xml file with the existing site.xml 
file, and copy the contents of the SCOPIA Connector features and plug-ins 
folders into the existing corresponding folders.

DISTRIBUTION 
METHODS FOR THE 
SCOPIA 
CONNECTOR 
PLUG-IN

You can distribute the SCOPIA Connector plug-in by using these methods: 
� “Pushing” the plug-in to all Lotus Sametime Connect users in a 

specified community.
The plug-in is automatically downloaded to the client when the user 
launches Lotus Sametime Connect. The user is notified of the update and 
can have the client restart automatically to load the new plug-in.
For more information, see How to Automatically Deploy the Plug-in on 
page 4.

� Sending the update site URL to users.
Users must then retrieve and install the plug-in manually using the Lotus 
Sametime Connect Manage Updates user interface.
For more information, see Manually Installing the Plug-in from an 
Update Site on page 6.
You can optionally prevent users from performing this procedure. For 
more information, see Preventing Manual Downloading on page 7.
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How to Automatically Deploy the Plug-in

HOW TO 
AUTOMATICALLY 
DEPLOY THE 
PLUG-IN

� Installing the Plug-in via the Community Client Document (for 
Administrators) on page 4

� Installing the Plug-in via the preferences.ini File (for End Users) on 
page 5

INSTALLING THE 
PLUG-IN VIA THE 
COMMUNITY CLIENT 
DOCUMENT (FOR 
ADMINISTRATORS)

This section describes how you can automatically deploy the SCOPIA 
Connector plug-in via the Sametime server Community Client Document.

 ) Procedure

1 Create an update site (see Update Sites for an explanation of 
update sites).

2 Open the stconfig.nsf file on the Sametime server. 
3 Double click the CommunityClient document.
4 Add the full path to your update site (including http://) in the 

URL for UIM Provisioning field.
5 Copy this URL to the Sametime update site URL field in the 

Policy which applies to the users.
6 Save and close the stconfig.nsf file.
7 Using the web-based server administrator 

(http://<server>/stcenter.nsf) log in as the administrator.
8 Click the Administer the server link.
9 Click the Policies link.
10 Click the Sametime Default Policy link.
11 In the Instant Messaging section, modify the Sametime update 

site URL with local update site on the Sametime server.
12 Click Go to save your changes.
13 Use another web page and run the Domino Server 

Administrator (http://<server>/webadmin.nsf).
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How to Automatically Deploy the Plug-in

14 Log in and click the Server tab at the top of the page.
15 Select Tools > Server > Restart to restart your Sametime 

server. 
The next time a user logs in to the Sametime Connect client, the plug-in 
is downloaded and the user is prompted to restart the Sametime client.

INSTALLING THE 
PLUG-IN VIA THE 
preferences.ini FILE 
(FOR END USERS)

This section describes how you can automatically deploy the SCOPIA 
Connector plug-in via the Sametime Connect preferences.ini configuration file.
The preferences.ini file is located by default at the following locations on the 
Sametime Connect client:

� Sametime 7.5.x
C:\Program Files\ibm\Sametime Connect\plugins\
com.ibm.collaboration.realtime.update_1.0.0

� Sametime 8.0
C:\Program Files\IBM\Lotus\Sametime Connect\shared\
eclipse\plugins\com.ibm.collaboration.realtime.update
_8.0.0.20071119-1552

 ) Procedure

1 Create an update site (see Update Sites on page 3 for an 
explanation of update sites).

2 Open the preferences.ini file. 
3 Type your update site URL as the value for the 

adminUpdatePolicyURL parameter. Use the format
adminUpdatePolicyURL=http://server.domain.com/

directoryname/site.xmls

4 Save and close the preferences.ini file.
The next time the user logs in to the Sametime Connect client, the client 
searches for the update site URL in the URL for UIM Provisioning 
parameter of the stconfig.nsf file on the Sametime server.
If the client fails to find the URL, the client searches for the value of the 
adminUpdatePolicyURL parameter of the preferences.ini file.
When the client finds this value, the plug-in is downloaded and the user 
is prompted to restart the Sametime client.
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Manually Installing the Plug-in from an Update Site

MANUALLY 
INSTALLING THE 
PLUG-IN FROM AN 
UPDATE SITE

This section describes how Sametime end users can manually install the 
SCOPIA Connector plug-in on a Sametime Connect client.
The SCOPIA Connector plug-in is available for download from an update site. 
For more information, see Update Sites on page 3.

Note Sametime Administrators may prevent end users from performing manual 
downloads. For more information, see Preventing Manual Downloading on 
page 7. 

 ) Procedure

1 In the Sametime Connect client user interface, choose 
(for Sametime 7.5 CF1) File > Manage Updates > Download Plugins 
(for Sametime 7.5.1 and 8.0) Tools > Plug-ins > Install plug-ins...

2 If you have a previous version of the plug-in already installed, 
the installer prompts you to search for updates to the currently 
installed features. In the Feature Updates window, choose 
Search for updates of the currently installed features, and 
then go to step 9.

3 If you do not have a previous version of the plug-in installed, 
in the Feature Updates window choose Search for new 
features to install, and click Next.

4 In the Update sites to visit window, click Add Remote 
Location (or New Remote Site for Sametime 7.5.1 CF1).

5 Type an update site name and URL.
For example, name “SCOPIA Connector” and URL 
http://<server>/sametime.

6 Click OK to save the location.
7 Click the checkbox for the new location.
8 Click Finish.
9 In the Search Results window, expand the tree labeled with the 

name that you typed at step 5 to view all available SCOPIA 
Connector plug-ins.

10 Choose the latest version of the SCOPIA Connector plug-in 
and click Next.
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Preventing Manual Downloading

11 In the Feature License window, accept the terms of the license 
agreement and click Next.

12 In the Installation window, click Finish.
13 Click Install or Install All.

If the installation is successful, you are prompted to restart the Sametime 
client to access to the new plug-ins.
Installation is now complete and the SCOPIA Connector plug-in 
Preferences window is now available.

PREVENTING 
MANUAL 
DOWNLOADING

This section describes how Sametime administrators can prevent end users from 
performing manual downloads to a Sametime Connect client.

 ) Procedure

1 On the Sametime server host machine, open the sametime.ini 
configuration file located at \Lotus\Domino. 

2 Under the [config] section, add the following line: 
DisableConnectPluginUpdates=1. 

3 Restart the server and reconnect with the client. 
The user options are grayed out.
In the Sametime Connect client user interface, the options under Tools > 
Plug-ins are disabled.

INSTALLING THE 
PLUG-IN WITHOUT 
AN HTTP SERVER

This section describes how to install the SCOPIA Connector plug-in in 
Sametime Connect client from a local file without using an HTTP server. To do 
this, you locate the update site in a shared network directory. Users can then 
access this directory from the Sametime Client interface.

 ) Procedure

1 Save the sametime directory to a shared network location.
2 In the Sametime Connect client user interface, choose choose 

Tools > Plug-ins > Install plug-ins....
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Installing the Plug-in without an HTTP Server

3 In the Feature Updates window choose Search for new 
features to install, and click Next.

4 In the Update sites to visit window, click Add Folder 
Location (for Sametime 8.0) or New Local Site (for Sametime 
7.5.1), navigate to the saved sametime directory and click OK.

5 Click Finish. The Sametime Connect client now searches for 
updates from the defined site.

6 In the Search Results window, select sametime. 
7 Type a new name for the directory and click OK, or leave the 

directory name unchanged.
8 Click Next.
9 In the Feature License window, accept the terms of the license 

agreement and click Next.
10 In the Installation window, click Finish.
11 Click Install or Install All.

If the installation is successful, you are prompted to restart the Sametime 
client to access to the new plug-ins.
Installation is now complete and the SCOPIA Connector plug-in 
Preferences window is now available.
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